Rickshaw by keppel (),  xantor ()

3D ModelsTransportationLand

Rickshaw

Requirements:  Poser 5 and above. DAZ Studio 3 and above. Any program capable of importing .obj files.

Departments:
3D ModelsTransportationLand
3D ModelsTransportation
3D ModelsProps