Sci-Fi Buildings bundle

Requirements:  Vue (created and tested on Vue8.4 Studio but SHOULD work on any version after 5.5.) NB. In order to automatically populate plants on to the planters as in the promo renders you must have the Vue Ecosystem module installed.

Departments:
Clearance/Deleted Promotion Week 5

Product Files:

ReadMe File

Exclusive Product

Coupons do not apply

Digital Product
File (1): 20.52 MB

Bookmark and Share


8.00 USD  •   56% Off  • Clearance

Price: 3.50 USD

 Add to Cart  Gift this Item  Add to Wishlist