Welcome to the Poser Forum

Forum Moderators:  Kendra, wheatpenny, Jules53757    Forum Coordinators:  darknewt, gmm2

Poser F.A.Q (Updated: 2019 Jan 31 1:28 pm)


 Subject: Missing files in scene - pose file?

scullygirl818 opened this issue on Apr 15, 2019 · 4 posts

Top of Forum Print

  scullygirl818    ( ) ( posted at 12:36PM Mon, 15 April 2019 

I had made a poser scene awhile ago, and since started to reinstall all of my runtimes using DIM (even though I use Poser a lot), because it makes it easier to keep track of. I don’t mean using their recommended folders in My Documents or anything either, they are all in separate runtimes; basically the structure I’ve always used, but installed with the program.

So after some computer problems, I realized that Poser was gone. I think it was because I was trying to update Windows and sometimes it just decides to delete things...anyway...so I reinstalled. I tried to open this old file which was linked to the old runtimes, but since it was asking where files were, I decided it made more sense to update all the links to the new runtime, so I searched each missing piece and reinstalled the ones that were missing that I hadn’t installed yet in the new runtimes. (Part of this was my fault every file asked, because I opened directly after install and forgot to add the runtimes to the program).

So the file opens, but there are two problems. First two objects I had in the scene are missing. I know where they are, but it didn’t ask me where they were (one was imported from DS, and one was imported from another Poser scene). The second thing, and the worse part, is that V4 is standing in the T pose. I am assuming maybe I didn’t install the pose pack, but it never asks for poses. I’m not sure what to do.

If there is no way to force it, is it possible to relink all the files to the old mapped runtime? If I reopen the original file, not the resaved version, that still says modified in 2017, it’s just connecting to the new runtime, it doesn’t ask me anymore. Would it be beneficial to remove all the runtimes from the program and add back the old runtimes only (I have both in there now)? Will it then ask me again? And how do I fix the pose? I’m absolutely sure it had to have been installed in the other runtime, because I have only worked on this scene on my laptop. I’m not even 100% sure which pose pack it came from.


  ironsoul    ( ) ( posted at 2:23AM Tue, 16 April 2019  · @4350154

Regarding the T pose issue, there is a command that needs to be run for V4 morphs to work, if you haven't done that might be worth doing. I don't have the details on me but details should be in install instructions.



  scullygirl818    ( ) ( posted at 2:18PM Fri, 19 April 2019  · @4350310

In V4 instructions or the morph packages? To clarify though, I think it’s the pose missing? I don’t think I used any morphs. I did realize though because I only installed the V4 clothes that the file had missing, I didn’t load any of the morph pack,so I fixed that. But it’s still not asking me where the files are. I never resaved that. Isn’t there a way to reset it and I’ll just link it all to the old runtime?


  ironsoul    ( ) ( posted at 6:48AM Sat, 20 April 2019  · @4350331

FYI - below is just me bouncing ideas off the wall, I can't reproduce the problem you are having...

The command I was thinking of is in Runtime\Libraries!DAZ\DzCreateExPFiles-V4.bat. The morph++ pack came with some pose morphs so the thought was maybe these were used with the pose pack - just a suggestion, not saying it is the problem.

Regarding location of resources - from problems I've had in the past I suspect once a scene is saved the location of the resources will also be saved in the file and this will override the normal runtime list. To check, go to a texture node and bring up Texture Manager, instead of selecting "Browse" select the inverted triangle above and the list of resource paths will be shown with a tick mark against the actual resource used. I've never succeeded in reseting this list. So one possible explanation of what's happening is Poser is using the search path stored in the scene file rather than the runtime search path configured for Poser. If this is the case maybe renaming the unwanted runtime will force Poser to search again...

Another possibility is the new set-up uses a different search order of runtimes so possibly Poser is finding a incomplete install. For example I have two runtimes "My Old DAZ Library" and "My New DAZ Library". If "My Old DAZ Library" is first on the list even if I select V4 from "My New DAZ Library" Poser will still grab textures and other resources from "My Old DAZ Library" due to the way the search system works. The Texture Manager check above should show this if this is the case. If you're happy to edit files, the LibraryPrefs.xml stores the library paths and moving one line above another appears to change the search order.



 To create a post you must first sign in or register an account.

Privacy Notice

This site uses cookies to deliver the best experience. Our own cookies make user accounts and other features possible. Third-party cookies are used to display relevant ads and to analyze how Renderosity is used. By using our site, you acknowledge that you have read and understood our Terms of Service, including our Cookie Policy and our Privacy Policy.