Welcome to the Poser Forum

Forum Moderators:  Kendra, wheatpenny, Jules53757    Forum Coordinators:  darknewt, gmm2

Poser F.A.Q (Updated: 2019 Jan 31 1:28 pm)


 Subject: Problem installing vicky 4 on Windows 7 Error reading INI file

dwj012754 opened this issue on Apr 27, 2012 · 6 posts

Top of Forum Print

  dwj012754    ( ) ( posted at 7:45AM Fri, 27 April 2012 

My previous laptop which ran Windows XP died, and the new one is Windows 7.  When I installed Poser 9, it defaulted to c:Program Files (x86)...    The program came up, but when I attempted to install Vicky 4, I got this error 'Error reading INI file C:Program Files (x86)Common FilesDAZdzInstall.ini.

Based on similar problem resolutions, I deleted Poser 9 and reinstalled in the root directory under c:Smith MicroPoser 9.  The program came up, but when I tried to install Vicky 4, it gives the exact same error message about the dzInstall.ini file mentioned above.

I have tried finding the file and even searched the registry with 'regedit', but cannot find a way to make the install program for DAZ look in the new location.

Has anyone else solved this problem and can give me a clue to get my content into the new Poser 9 installation?


  basicwiz    ( ) ( posted at 7:49AM Fri, 27 April 2012  · @3921943

In Windows explorer, create this exact path, ending with a blank file dzInstall.ini created with a text editor.

Should fix you right up.


  bagginsbill    ( ) ( posted at 7:56AM Fri, 27 April 2012  · @3921945

bw has told you a solution, but I wanted to clarify a couple misunderstandings implied by the original post.

 

  1. "I deleted Poser 9 and reinstalled" - this was pointless, as the daz installer is looking for evidence of previous uses of the daz installer - not Poser.

2) "I have tried finding the file" - and so was the installer - the error it was giving was that the file doesn't exist. Looking for it elsewhere wasn't going to do any good. The installer needs it to exist exactly in the path it stated: .../Common Files/DAZ/dzInstall.ini 

  1. This is happening having nothing to do with Poser. It's happening because DAZ made an install utility that violates Windows 7 rules. It is not allowed to create files in Program Files. The reason Poser 9 doesn't keep its runtime in Program Files is exactly that - installers are not allowed to modify Program Files content. DAZ should have updated these installers two years ago but they just don't bother. As a result, we (in this forum) have to explain this over and over and over and over and over and over and over and over and over.

  2. Your solution is to manually work around the installer's stupid requirement. All it cares about (for no good reason) is that the specified file needs to exist. This is completely artificial and has no consequences of any kind, other than letting you finish the installation. The actual contents of this dzInstall.ini file is absolutely unimportant. All you have to do is cause such a file to exist. The easiest way is to open notepad and then File/Save and give that path.

 


Renderosity forum reply notifications have been wonky in the past. I'm testing the waters to see if it's working now. If you ask me something and I don't come back, it probably isn't. (Updated January 17, 2017)

  dwj012754    ( ) ( posted at 8:05AM Fri, 27 April 2012  · @3921949

Thanks very much for the reply.  I did create an empty file with the exact path and name and then the dialog popped up to allow me to browse to the new runtime location.

I had searched for the problem in the forums and you had several posts on the subject.  This response was perfect for me.  I appreciate the help.

 


  bagginsbill    ( ) ( posted at 8:09AM Fri, 27 April 2012  · @3921950

Excellent!


Renderosity forum reply notifications have been wonky in the past. I'm testing the waters to see if it's working now. If you ask me something and I don't come back, it probably isn't. (Updated January 17, 2017)

  RHaseltine    ( ) ( posted at 8:55AM Fri, 27 April 2012  · @3921967

Strictly, since it's an installer the dzintall.ini file could be edited or created just fine - the problem with content in the application folder is that applications shouldn't routinely run with admin rights, as Poser would need to to be able to add files to the content library (this applies to most of the content focussed applications - Poser, DS, Carrara, Vue etc.). In any event the recent installers don't create the file there, and the error of failing if the file doesn't exist has also been fixed - but that leaves the legacy installers that do need the blank file trick if you run one of the badly set up ones on a clean machine.


 To create a post you must first sign in or register an account.

Privacy Notice

This site uses cookies to deliver the best experience. Our own cookies make user accounts and other features possible. Third-party cookies are used to display relevant ads and to analyze how Renderosity is used. By using our site, you acknowledge that you have read and understood our Terms of Service, including our Cookie Policy and our Privacy Policy.