Touchable Perfect Pony by -Wolfie- ()

3D Figure AssetsAddOnsHair

Touchable Perfect Pony

Software:   Daz Studio 4, Poser 9 / Poser Pro 2012 +, DAZ Studio 4 With IRAY

File Types:   (not specified)

Requirements:  Poser 9+, Daz Studio 4+, Daz Studio 4.8+ (for Iray)

Required Products:   Perfect Ponytail Hair G2F and G3F With Dson

Departments:
3D Figure AssetsAddOnsHair

Related Products