Spring Wear Dressing Bundle (V4.2 Elite,A4,S4,G4) by jasmina ()

3D Figure EssentialsClothing

Spring Wear Dressing Bundle (V4.2 Elite,A4,S4,G4)

Warning! Content Advisory:  Some images may contain content not suitable for all viewers

Requirements:  Poser 6 or DAZ Studio 4 (for DS, MAT poses may need to be adjusted) , used with DAZ3D Victoria 4 (Tested with P6,P7,P8 and Poser pro 2010 on PC)

Departments:
3D Figure EssentialsClothing
SoftwareUtilities