Distressed Denim by mystikel ()

2DDecos

Distressed Denim

Requirements:  Photoshop 7+ for the .psd file (photoshop layers) and brushes. Any graphics editting program to use the .jpg tiles.

Departments:
2DDecos
2DBrushes
2DTextures

Related Products


Fabric Texture Brushes

By mystikel

8.00 USD     30% Off

5.60 USD

Wrinkle Brushes

By mystikel

8.00 USD     30% Off

5.60 USD

Leather Texture Set

By mystikel

8.00 USD     35% Off

5.20 USD

Tie Dye Brushes

By mystikel

8.50 USD     30% Off

5.95 USD


 Previous Next 


8.50 USD     30% Off
Ends: Sep 07

Price: 5.95 USD



193 0



Best Selling