Wave Hair for M4 by TruForm ()

3D Figure EssentialsHair

Wave Hair for M4

Requirements:  Daz Studio 2.3 or later, Poser 7 or later, Michael 4

Departments:
3D Figure EssentialsHair

Related Products


Hair for M4

By TruForm

8.00 USD


Customers Who Bought This Item Also Bought


 Previous Next 


Price: 8.00 USD



285 0