Dynamo Kid for The PreTeen by Oskarsson ()

3D Figure EssentialsClothing

Dynamo Kid for The PreTeen

Requirements:  Poser 6 or higher. PC or Macintosh. Victoria 4.a with morph++. The PreTeen Starter Pack. Materials will not work in Daz Studio

Departments:
3D Figure EssentialsClothing


Related Products