Party Dressing Bundle (V4.2 Elite,Aiko4,GND4)(DS3 and Poser) by jasmina ()

3D Figure EssentialsClothing

Party Dressing Bundle (V4.2 Elite,Aiko4,GND4)(DS3 and Poser)

Requirements:  Poser 6, 7 or above or DAZ Studio 3 used with DAZ3D Victoria 4 (Tested with P7 on PC), Python program is compatible with PC and MAC.

Departments:
3D Figure EssentialsClothing
3D Figure EssentialsAddOnsClothing
SoftwareUtilities