ScaleZ by patslash ()

2DBrushes

ScaleZ

Requirements:  Photoshop 7 or newer for the brush file and any program that opens .png files for the image pack

Departments:
2DBrushes
2DDecos

Related Products