Distressed Denim by mystikel ()

2DDecos

Distressed Denim

Requirements:  Photoshop 7+ for the .psd file (photoshop layers) and brushes. Any graphics editting program to use the .jpg tiles.

Departments:
2DDecos
2DBrushes
2DTextures

Related Products


Leather Texture Set

By mystikel

8.00 USD     35% Off

5.20 USD


 Previous Next 


Price: 8.50 USD



193 0