AO5: Euphoria for V4 by outoftouch (),  _Al3d_ ()

AO5: Euphoria for V4

Requirements:  Poser 4.01 or higher; Victoria 4 @ Daz3D

Departments: