Welcome to the Poser - OFFICIAL Forum

Forum Moderators: Digitell, CHMedia Forum Coordinators: RedPhantom

Poser - OFFICIAL F.A.Q (Last Updated: 2022 May 23 10:44 am)


Subject: Not All Of Scene Saved


MeInOhio ( ) posted Mon, 28 March 2022 at 9:37 PM · edited Mon, 23 May 2022 at 6:29 AM

The other day I created a scene and rendered it and exported the render. Then I saved the scene. When I re-opened the scene, all I had was the figure still posed and sitting in the dark. All the scenery and props were gone as well as all the lights.

While I was working on the scene, I converted Michael 4's textures using SkinEdit 12; a script for Poser sold at Renderosity.  The skin looked really good so I wanted to save it as a Mat file in the Pose Library since that's where the majority of those files live. But I wasn't sure about the choices I was going in the dialogue box, so I ultimately didn't save. I had unchecked some things in the dialogue box that I didn't want saved, because all I wanted was the Skin texture. I only mention this because I'm not sure if it had anything to do with why the full scene didn't save.

I created a couple of other scenes and I don't think I had any issue.

Then today I was working on a scene. I needed some water so I searched on how to make some (when I didn't find a shader in my library.) I added followed the steps and then saved my scene. I had more work to do on the scene. Later, I re-opened and all the scene seemed to be there. I used EZDome to create the BG and lights and then I tried to AREA render the water, but all I got was a tan square. I checked the material room, but not of the changes I made to the shader had been saved. For the water I was using a single sided square. 

Anyone have any idea why this happened. I don't think the square had more than one material zone, but I'll have to go back and check.

When I re-saved the revised scene, I re-opened it and this time everything was there just as I saved it.  And when I save, it is just a one shot thing. Poser isn't opening a dialogue box where I am choosing what I want to save.


hborre ( ) posted Mon, 28 March 2022 at 10:14 PM

Just for clarification, which version of Poser are you using and how exactly are you saving your scene?  Whenever I save a scene, I don't encounter any dialogue prompting me to select content.  The only feature that does that is the export partial scene where a dialogue panel will prompt you to select what you want to save.  Saving shader textures, on the other hand, should be done in the Material Room, not the Pose Room.  Although the files between the 2 rooms are similar in structure, there is one key line in the coding that defines how the file installs, either a MATpose or Material file.  As for the water plane, what render engine are you using, Firefly or Superfly?  The way the shader is composed in the Material Room may make a big difference in whether it will render properly or not.    Without seeing a screencap of that shader in the Material Room, I wouldn't know where the problem is.


MeInOhio ( ) posted Tue, 29 March 2022 at 9:06 AM · edited Tue, 29 March 2022 at 9:06 AM

I am using Poser 12. For as long as I have used Poser, I have always gone to the File Menu and selected Save or Save As. Never had an issue until these two instances, as far as I know. Although I don't often go back and open scenes once I've finished and rendered. I don't encounter any dialogue box either when I use Save or Save as, that's why I'm surprised it only save a partial scene.

I did ultimately save my Material Pose for Michael to the material room. I am using Superfly to render. I am attaching my water setup.

dPNPiqKtoNIWKqneZoBzBemfp6GDpKPSscmLNk8B.png


The first time I saved the Scene (File\Save) I had this setup. Later in the day when I re-opened the scene to continue my work, the two nodes were gone.  The only thing that showed was the PoserSurface panel. 

And I think I just solved this mystery. Apparently when I was creating the original shader, I had the ground selected and not the square which was the "water."


randym77 ( ) posted Tue, 29 March 2022 at 9:32 AM

Could you have accidentally added the lights and scenery in a frame other than the first one?

I've found Poser always opens to Frame 1, even if you were on Frame 30 (or whatever) when you saved the file.




hborre ( ) posted Tue, 29 March 2022 at 11:15 AM

Yeah, the partial scene save is a big mystery especially since you described the method everyone uses typically to archive their work.  It either sounds like a misbehaving launch of the app or you were maxing out your RAM capacity affecting Poser's performance.  


Wequonary ( ) posted Tue, 26 April 2022 at 9:37 AM

It really might be a problem with your RAM, and I had a similar situation. You may buy some storage special for your work at Poser. A big data warehouse is a big challenge, and you must approach this question with care to protect your data. I found a great post to read on this theme. As it says, aware is forearmed. :)


Wequonary ( ) posted Tue, 26 April 2022 at 10:12 AM · edited Tue, 26 April 2022 at 10:13 AM
Wequonary posted at 9:37 AM Tue, 26 April 2022 - #4437750

It really might be a problem with your RAM, and I had a similar situation. You may buy some storage special for your work at Poser. A big data warehouse is a big challenge, and you must approach this question with care to protect your data. I found a great post to read on this theme and even use some information from there for my university research. As it says, aware is forearmed. :)

Did you already fix your problem?


DCArt ( ) posted Tue, 26 April 2022 at 3:17 PM

I suspect the issue is that the materials you created used resources that were not saved to a local runtime or an external runtime in Poser. That would explain the black materials in the scene.  Did you get any error warnings about missing resources when you tried to open the scene?



MeInOhio ( ) posted Tue, 26 April 2022 at 6:52 PM

I haven't had any problem since then.

I don't think it's my memory. I have a new machine. And there has been no problem with anything else.

I don't know for sure what happened with the scene that didn't fully save, but I have a suspicion. I was trying to save a material preset for a skin texture to the pose library since that's where all the others seem to be. But I guess you can't do that directly. You have to save it to the Material Library. But somehow they get them into the Pose library because a lot of 'em live there.

IN any case, I think later on I went to open my scene. I always go to the Recent files drop down and I'm guessing that the pose file  was listed there and I opened it thinking it was the scene file. That's my best guess anyway.


SamTherapy ( ) posted Thu, 28 April 2022 at 6:13 AM
Online Now!

In the bad old days of Poser, material settings were saved to the Pose library, and for some time after, people continued to do it, because, well, old habits die hard.  Technically, anything that doesn't load geometry is a pose, so you can - or could - save just about anything anywhere with the right file extension.  Whether this has changed with later versions, I don't know.  

Was a time when there was a hard coded limit on the number of folders per library, and subfolders weren't supported, either.  Compounding that, only one Runtime was allowed.  I know, it was silly, but there you go.  Consequently, Pose used to fill up rapidly, so people started shoving stuff into the Camera folder instead, since it was hardly used.

Anyhow, since those days are gone, it's considered good form to stick things where they should go; poses in Pose, lights in Lights, materials in Materials and so on, with none of that other malarkey.

Coppula eam se non posit acceptera jocularum.

My Store

My Gallery


Privacy Notice

This site uses cookies to deliver the best experience. Our own cookies make user accounts and other features possible. Third-party cookies are used to display relevant ads and to analyze how Renderosity is used. By using our site, you acknowledge that you have read and understood our Terms of Service, including our Cookie Policy and our Privacy Policy.